Connecting Extreme and Cisco Networks

25th August 2017 by Martin Flammia

Filed under Extreme Networks EXOS, Featured Article

Last modified 30th September 2017

Recently had a installation where an Extreme Networks was replacing a Cisco, and the transition required both networks to work in parrallel and therefor be connected.

Typically I would do this via OSPF, but in this scenario it wasn’t an option – so the answer come in the form of multiple VRRP based on the conversation on the Extreme Networks Hub here

The process in summary evolves around around creating a common VLAN and subnet between both the Extreme Networks and Cisco, configuring VRRP with a different VRID for Extreme and Cisco, and then using the VIP addresses of each to create static entries to point the traffic in different directions.

Initially I looked into adding floating routes, flow-redirect, software port redundancy etc but it was becoming complicated to introduce on both sides of the network and I was concerned of getting asymmetric routing, or routing loops… the VRRP solution ended up providing a very elegant and simple means of to fix the problem.

Below is provided a diagram that hopefully is self explanatory, and the various commands on both the Extreme and Cisco. Hopefully there is also some additional elements there that might be useful, like creating a LAG / Port-channel between Extreme and Cisco, MLAG and multiple VRRP (mVRRP)

One caveat DO NOT add the VLAN either between the Ciscos Cores or between the Extremes Cores as you will get a loop! VRRP is still able to work because it can pass the messaging across the same VLAN via the other core pairs i.e. in the example provided Cisco Core 1 passes via Extreme Core3 -> Extreme Core 4-> and to Cisco Core 2

Here is what the config for both Extreme and Cisco would look-like…. Once additional note, I initially used VLAN 3999 but the Cisco system I attached to could use VLAN numbers that high, so resorted to VLAN 999

#### Extreme Core 3 ####

enable sharing 44 grouping 44
enable sharing 43 grouping 43

configure ports 43 description-string "Interlink-VRRP-Core1-Prt9/16"
configure ports 44 description-string "Interlink-VRRP-Core2-Prt8/16"

enable mlag port 44 peer "MLAG-PEER-2" id 944
enable mlag port 43 peer "MLAG-PEER-2" id 943

create vlan "Interlink-VRRP-Cisco"
configure vlan "Interlink-VRRP-Cisco" tag 999
configure vlan "Interlink-VRRP-Cisco" add ports 44,43,61 tagged
configure vlan "Interlink-VRRP-Cisco" ipaddress 10.0.254.178 255.255.255.248
enable ipforwarding vlan "Interlink-VRRP-Cisco"

create vrrp vlan "Interlink-VRRP-Cisco" vrid 101
configure vrrp vlan "Interlink-VRRP-Cisco" vrid 101 add 10.0.254.177
configure vrrp vlan "Interlink-VRRP-Cisco" vrid 101 priority 150
enable vrrp vlan "Interlink-VRRP-Cisco" vrid 101

configure iproute add default 10.0.254.182

#### Extreme Core 4 ####

enable sharing 44 grouping 44
enable sharing 43 grouping 43

configure ports 44 description-string "Interlink-VRRP-Core1-Prt9/16"
configure ports 43 description-string "Interlink-VRRP-Core2-Prt8/16"

enable mlag port 44 peer "MLAG-PEER-1" id 944
enable mlag port 43 peer "MLAG-PEER-1" id 943

create vlan "Interlink-VRRP-Cisco"
configure vlan "Interlink-VRRP-Cisco" tag 999
configure vlan "Interlink-VRRP-Cisco" add ports 44,43,61 tagged
configure vlan "Interlink-VRRP-Cisco" ipaddress 10.0.254.178 255.255.255.248
enable ipforwarding vlan "Interlink-VRRP-Cisco"

create vrrp vlan "Interlink-VRRP-Cisco" vrid 101
configure vrrp vlan "Interlink-VRRP-Cisco" vrid 101 add 10.0.254.177
enable vrrp vlan "Interlink-VRRP-Cisco" vrid 101

configure iproute add default 10.0.254.182

#### Cisco Core 1 ####
(conf t) vlan 999

interface Vlan999
ip address 10.0.254.180 255.255.255.248
vrrp 201 description "VRRP-Cisco-Extreme"
vrrp 201 ip 10.0.254.182
no vrrp 201 preempt

interface port-channel 201
description "Interlink-VRRP-Extreme-Core3"
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 999
switchport mode trunk

interface GigabitEthernet9/16
switchport
description "Interlink-VRRP-Extreme-Core3"
channel-group 201 mode on

interface GigabitEthernet8/16
switchport
description "Interlink-VRRP-Extreme-Core4"
channel-group 201 mode on

ip route 10.0.0.0 255.0.0.0 10.0.254.177

#### Cisco Core 2 ####
(conf t) vlan 999

interface Vlan999
ip address 10.0.254.181 255.255.255.248
vrrp 201 description "VRRP-Cisco-Extreme"
vrrp 201 ip 10.0.254.182
vrrp 201 priority 150
no vrrp 201 preempt

interface port-channel 201
description "Interlink-VRRP-Extreme-Core3"
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 999
switchport mode trunk

interface GigabitEthernet9/16
switchport
description "Interlink-VRRP-Extreme-Core3"
channel-group 201 mode on

interface GigabitEthernet8/16
switchport
description "Interlink-VRRP-Extreme-Core4"
channel-group 201 mode on

ip route 10.0.0.0 255.0.0.0 10.0.254.177

Leave a Comment